Redaktoriai

Iš GTA-Online Wikipedia.
Peršokti į: navigaciją, paiešką

Turinys

Pawno

Apie

„Pawno“ - tai specialus tekstinių bylų redaktorius, pagrinde skirtas darbui su „pwn“ tipo bylomis bei leidžiantis jas sukompiliuoti „amx“ formatu. Šios programos autorius spookie.

Išvaizda

Atsisiuntus SA-MP serverio Windows operacinės sistemos failų archyvą, jame rasime ir papildomą programą "Pawno". Pabandykime ją įjungti, du kartus paspaudę ant programos "pawno.exe". Programai įsijungus, matome tokį vaizdą:

Pawno 1 I3.png

Bylų kūrimas, saugojimas bei atidarymas

Prieš pradėdami programuoti, susipažinsime su pagrindiniais šios programos įrankiais, kurie ateityje mums padės daug greičiau rašyti. Pirmiausia susikurkime naują bylą, atsidarę skiltį "File" > "New" arba paspaudę mažą piktogramą su baltu lapu. Turėtumėte pastebėti, jog baltame fone atsirado tam tikras tekstas. Tai ir bus vieta, kurioje programuosite.

Pawno 2 I3.png

Kadangi jau žinome, kaip sukurti bylą, reikia išmokti kaip ją išsaugoti. Norint tai pdaryti, jums reikia atverti skiltį "File" > "Save" arba paspausti mažąpiktogramą su mėlynu diskeliu. Atsidariusiame naujame lange įrašome norimą būsimo failo pavadinimą ir spaudžiame "Save". Failas susikūrė jūsų nurodytame aplanke. Dabar išjunkime "Pawno" programą, tam, kad išmoktumėmę atidaryti jau egzistuojančią bylą. Įsijungę iš naujo "Pawno", atverkite skiltį "File" > "Open" arba paspauskite mažą piktogramą su atvertu aplanku bei šalia esančia rodykle. Atsidariusiame lange, susiraskite prieš tai išsaugotą dokumentą bei jį pažymėję, paspauskite "Open". Kaip matote, byla buvo sėkmingai atidaryta.

Teksto paieška

Berašant ilgą kodą, programuotojui būna gana keblu slankioti per visą tekstą kol suranda tam tikrą dalyką. Norint išvengti tokių atvejų, "Pawno" turi paieškos funkciją. Norėdami surasti tam tikrą dalyką atverkite skiltį "Edit" > "Find" arba paspauskite mažą piktogramą su žiūronais. Atsivėrusiame lange į teksto įvedimo langelį įrašykite kokį nors paieškoks žodį bei paspauskite "OK". Programa automatiškai suras visus rastus įrašus atitikusius paieškos žodį. Taippat, jog rezultatai būtų kuo tikslesni galite pasirinkti ir daugiau nustatymų, tokių kaip raidžių dydis, jų vietą sakinyje, paieškos kryptį ar net plotą. Norėdami peržiūrėti kitus rastus paieškos įrašus, atverkite skiltis "Edit" > "Find Next", "Edit" > "Find Prev" arba pasinaudokite mažoimis piktogramomis su žiūronais bei prie jų esančiomis rodyklėmis.

Teksto keitimas

Sekantis įrankis, kurį aptarsime, labai praverčia kuomet reikia pakeisti didelį kiekį vienodų dalykų. Atverkite skiltį "Edit" > "Replace" arba paspauskite mažą piktogramą su raidėmis "a b" bei šalia esančiomis rodyklėmis. Atsivėrus naujam langui į pirmą teksto įvedimo lauką įrašykite tokią teksto dalį, kurią keisite, o į antrą - tekstą, į kurį bus pakeisti rasti įrašai. Paspaudus "OK", programa radusi pirmąjį įraša jį pažymės bei paklaus ar tikrai pakeisti rastą įrašą nurodytu tekstu. Paspaudę "Yes to all", programa pakeis visus rastus įrašus iškarto nebepaklausus to paties.

Naršymas

Dar vienas įrankis padėsiantis greitai "keliauti" per kodą yra atvėrus skiltį "Edit" > "Go to...". Su juo, programa mus nukels iškarto į pasirinktą eilutę.

Greitieji klavišai

Kompiliavimas

Apibendrinimas

Asmeniniai įrankiai
San Andreas Multiplayer